Project-Id-Version: Trac 0.12
Report-Msgid-Bugs-To: trac-dev@googlegroups.com
POT-Creation-Date: 2008-01-30 09:20+0100
PO-Revision-Date: 2010-07-19 23:05+0200
Last-Translator: Jeroen Ruigrok van der Werven <asmodai@in-nomine.org>
Language-Team: en_US <trac-dev@googlegroups.com>
Plural-Forms: nplurals=2; plural=(n != 1)
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit
Generated-By: Babel 0.9.6

Warning: Can't synchronize with repository "(default)" (Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? ). Look in the Trac log for more information.

Ticket #180 (accepted improvement)

Opened 7 years ago

Last modified 7 years ago

Transelating in to norwegian

Reported by: emby Owned by: sebastian
Priority: minor Milestone: 2.2
Component: unspecified Version:
Keywords: Cc: embytime@gmail.com

Description

Hi

Om working on transelating phTagr into Norwegian (nno). I'll send the default.[mp]o when it's all good.

I've a couple of things I need help with. I need to transelate the email tekst. I've started transelating the files in "phtagr/View/Emails", but I can't find the header tekst "[phtagr] Welcome username" here, nor the "Email was sent by the open source social web gallery phTagr, http://www.phtagr.org"?

I get a problem with the norwegian æøå. I think this is a utf-8 problem. I've set up ssmtp for my e-mail, but I've seen that there is a possibility to use smtp from phtagr and that you can choose utf-8 there? I tried to do this, but ended up loosing ability to send email. I had to revert to a backup.

I also get a problem with the æøå when I download the files from phtagr (think this is a utf-8 problem.

Another thing is the filter where you can write "tag:animal". How can I transelate the tekst in the filterbox? I would like to be able to write etikett: in sted of tag:

Change History

comment:1 Changed 7 years ago by sebastian

  • Owner set to sebastian
  • Status changed from new to accepted

That are great news! Thank you very much to translate phTagr to Norwegian! Looking forward to it!

I've updated the localization of the email view and subjects. Please update your source code (HowToMigratePhtagr) and your translation file (UpdateYourLanguage).

Regarding finding a text, the unix command grep is your friend! Try 'grep -nHr "Email was sent by" *' and you will find your file which are your looking for.

Regarding UTF8: Have might have luck with just enable a configuration setting in Config/core.php: Enable

setlocale(LC_CTYPE, "UTF8", "en_US.UTF-8");

there. Further your translation in poedit should be UTF8 as well. Please check the Internet to crosscheck your translation file. phTagr should be fine with special chars - at least I did not had any troubles with German's umlaut. For further digging to solve your problem: Could you describe your system? Which OS, PHP version are you using?

Regarding translating of 'tag': I've opened an extra ticket #181 (Allow translation of filter query keys like 'tag') since it isn't a small change and needs some magic inside the code.

comment:2 Changed 7 years ago by emby

Hi!

Sorry for the late reply! I've been down with the flue.

Thank you for making the changes in Emailview and changig the default.pot!

When i updatet to latest dev today i got this errormessage when I tried to register a new account:
"Parse error: syntax error, unexpected ';' in /var/www/test/git/View/Emails/text/new_account_confirmation.ctp on line 2"

The code is:
"echo ("Hello %s!", $userUser?username?;"

It should be:
echo ("Hello %s!", $userUser?username?);

echo ("\n");"

You forgot the ")" at the end of line 2 and 3.

I'm running Ubuntu 10.04.4 LTS server with PHP 5.3.2-1ubuntu4.17 with Suhosin-Patch.

The emails are fine now with "æøå" after the transelation, will the line:

setlocale(LC_CTYPE, "UTF8", "en_US.UTF-8");

work for the filedownloadissue with æøå?

comment:3 Changed 7 years ago by sebastian

Thank you for reporting the syntax error. I've fixed it in new_account_confirmation.ctp.

I do not understand your line: 'work for the filedownloadissue with æøå?'

comment:4 Changed 7 years ago by emby

Sorry! Realy bad sentence.

When I download a file from phtagr, æøå in the filename becommes somtehing else.

Did that help?

comment:5 Changed 7 years ago by sebastian

Yes, now it makes sense (And I also saw again your first description of this bug entry). I think this the filename stuff is another bug and I opened ticket #184 for it.

Have you checked again to upload and download a file with international characters after you applied setlocale?

comment:6 Changed 7 years ago by emby

Gone check it first thing monday. Have a nice weekend Sebastian!

comment:7 Changed 7 years ago by sebastian

Have nice weekend, too. Thanks for testing!

comment:8 Changed 7 years ago by emby

I still get this problem after adding setlocal. Could this be something outside phTagr?

comment:9 Changed 7 years ago by sebastian

I've updated the source 19e7117 and think this change will fix you problem. I've tested a file with ö and ß and could download it via explorer and via file browser in the backend.

Could you update your source (via git, or change Controller/BrowserController?.php like the git commit) and can check it again?

Thank you very much in advance!

comment:10 Changed 7 years ago by emby

Hi

When i download one picture from explorer (I push download on the image) i have no problem now (æøå works), but if I select a few images, push more > download original, i still have the problem.

Until now I did not notice there was a difference between these two ways of downloading.

While testing I noticed that when I upload pictures phtagr overwrites øæå with a "-". I had to download a file that was importet from the filebrowser in the backend.

This is a different issue, but i can't download the pictures that I've importet in the backend. I just get a blanck page and nothing happens. I can only download pictures uploaded in the frontend from the backend. Therfore I don't know if the issue with øæå persists there.

comment:11 Changed 7 years ago by sebastian

Error on upload might be caused by used upload library plupload. plupload might change the filename on upload or the plupload connector to phtagr can be improved. See also http://www.plupload.com/punbb/viewtopic.php?id=1511

Error on multiple download is caused by used on-the-fly zip library ZipStream? library by A. Grandt. ZipStream? might handle UTF8 filenames incorrectly. Maybe lib-zipStream.php by Paul Duncan from zenphoto helps?

Unfortunately, both errors will need some time to fix it.

Note: See TracTickets for help on using tickets.