Project-Id-Version: Trac 0.12
Report-Msgid-Bugs-To: trac-dev@googlegroups.com
POT-Creation-Date: 2008-01-30 09:20+0100
PO-Revision-Date: 2010-07-19 23:05+0200
Last-Translator: Jeroen Ruigrok van der Werven <asmodai@in-nomine.org>
Language-Team: en_US <trac-dev@googlegroups.com>
Plural-Forms: nplurals=2; plural=(n != 1)
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit
Generated-By: Babel 0.9.6

Warning: Can't synchronize with repository "(default)" (Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? ). Look in the Trac log for more information.

Ticket #156 (closed bug: fixed)

Opened 7 years ago

Last modified 7 years ago

Rotation labels incorrect

Reported by: scottme Owned by: sebastian
Priority: minor Milestone: 2.4
Component: explorer Version:
Keywords: image, rotation Cc:

Description

The edit metadata option in the gallery view shows four buttons for rotation of selected images: Keep, 90 CW, 180CW, 90 CCW.

However, the "90 CW" button actually rotates images counter-clockwise. For example if an image is displayed with ← orientation, after applying a "90 CW" rotation it appears with ↓ orientation instead of the expected ↑. Similarly the "90 CCW" button actually rotates clockwise, turning → into ↓ instead of ↑.

And while you're at it, the "180 CW" button might just as well leave off "CW" because it makes no difference whether a 180° rotation is CW or CCW.

Change History

comment:1 Changed 7 years ago by sebastian

  • Keywords image, rotation added
  • Owner set to sebastian
  • Status changed from new to assigned

Thank you for reporting this bug.

Which version of phtagr are you using since I can not reproduce this issue on the current master. There was also an fix in November 2011 (https://github.com/xemle/phtagr/commit/2b2d5663f45e7296ee406226ccbfdc3eeb528306). Maybe updating is fixing this problem.

Best regards

Xemle

comment:2 Changed 7 years ago by sebastian

  • Milestone set to 2.4

comment:3 Changed 7 years ago by sebastian

  • Status changed from assigned to closed
  • Resolution set to fixed

There was strange behavior of used thumbnail 3rd party library phpthumb. phpthumb rotated images different if GD or ImageMagick?'s convert was used. This was fixed in 8c5c137

Note: See TracTickets for help on using tickets.