Project-Id-Version: Trac 0.12
Report-Msgid-Bugs-To: trac-dev@googlegroups.com
POT-Creation-Date: 2008-01-30 09:20+0100
PO-Revision-Date: 2010-07-19 23:05+0200
Last-Translator: Jeroen Ruigrok van der Werven <asmodai@in-nomine.org>
Language-Team: en_US <trac-dev@googlegroups.com>
Plural-Forms: nplurals=2; plural=(n != 1)
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit
Generated-By: Babel 0.9.6

Warning: Can't synchronize with repository "(default)" (Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? ). Look in the Trac log for more information.

Ticket #155 (closed bug: fixed)

Opened 7 years ago

Last modified 7 years ago

Could not upload any image,zip,...

Reported by: waswrongassembled Owned by: sebastian
Priority: blocker Milestone:
Component: file browser Version: 2.0
Keywords: upload, file Cc: waswrongassembled@mac.com

Description

After installing the software I'm not able to upload. All I got is 'Invalid path for upload' / 'Ungültiges Uploadverzeichnis' even if I try to look into the Media Files --> Uploaded.

Blocker, because I can not work with it.

Change History

comment:1 Changed 7 years ago by waswrongassembled

Addendum: I installed it with on a server configured with Plesk 10.4.4

comment:2 Changed 7 years ago by sebastian

  • Owner set to sebastian
  • Status changed from new to assigned

Thank you for reporting this issue.

To give some help additional information is required.

  • Which (exact) bversion of phTagr are you using?
  • Do you have external paths configured?
  • Where do you click on 'Upload'?

While installing phTagr its setup procedure checks that upload files can be written. So I guess you should be able to upload in some way since you installed phtagr.

Can you upload files by http://localhost/phtagr/browser/quickupload (Replace 'localhost/phtagr' to your server address)?

BR

Xemle

comment:3 Changed 7 years ago by waswrongassembled

Hi,

I tried the following versions with same result:

  • phtagr-master-3054f551
  • phtagr-2.2b2

Yes, I configured the external paths/programms. It was not taken/saved during installation so I configured it again afterwards.

If I try to load something via quickupload the files were uploaded but then only this error is shown: 'Error: Invalid upload directory' - nothing more. No picture is saved.

If I try to clickUpload in the Dashboard (under Media Files) the message: 'Invalid path for upload' and the browser index view is shown.

comment:4 Changed 7 years ago by sebastian

  • Keywords upload, file added
  • Component changed from unspecified to file browser

Unfortunately, I could not reproduce this error with these version. At least the quick upload should work out of the box on correct configuration.

Please check if your web server can write to directories in phtagr/users and phtagr/tmp directory. Does the log file logger.log in phtagr/tmp/logs gives some more details about this issue? Is it possible to attach your logger.log file to the ticket?

Further, if you have configured external directories to import files (e.g. from your Desktop or Picture folder) the file browser has a small bug: You have to select first phtagr's internal 'files' folder in Dashboard -> Media Files before uploading files via Dashboard -> Media Files -> Upload menu entry.

Best regards, Xemle

comment:5 Changed 7 years ago by waswrongassembled

Ok I got it. Plesk and its default setup. (php.ini)
open_basedir and safe_mode were on so phtagr was not able to create the directories it needed.
Thx for pushing me in the right direction...

;-)

comment:6 Changed 7 years ago by sebastian

Thanks for the update! So I can close ticket #154 and #153?

If you dont mind I would appreciate it if you add your knowledge of installing phtagr with plesk on a wiki page - something like HowToInstallWithPlesk?

Thank you again for installing phTagr and reporting your issues.

Xemle

comment:7 Changed 7 years ago by waswrongassembled

You can close #154 & #155 and yes, if have have the time I'll put some lines in your wiki.

BR André

comment:8 Changed 7 years ago by sebastian

  • Status changed from assigned to closed
  • Resolution set to fixed

Thank you for the wiki page! See HowToInstallWithPlesk for details

Note: See TracTickets for help on using tickets.