Project-Id-Version: Trac 0.12
Report-Msgid-Bugs-To: trac-dev@googlegroups.com
POT-Creation-Date: 2008-01-30 09:20+0100
PO-Revision-Date: 2010-07-19 23:05+0200
Last-Translator: Jeroen Ruigrok van der Werven <asmodai@in-nomine.org>
Language-Team: en_US <trac-dev@googlegroups.com>
Plural-Forms: nplurals=2; plural=(n != 1)
MIME-Version: 1.0
Content-Type: text/plain; charset=utf-8
Content-Transfer-Encoding: 8bit
Generated-By: Babel 0.9.6

Warning: Can't synchronize with repository "(default)" (Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? ). Look in the Trac log for more information.

Ticket #142 (closed bug: fixed)

Opened 8 years ago

Last modified 7 years ago

Webdav - howto?

Reported by: dgBoldt Owned by: sebastian
Priority: major Milestone: 2.4
Component: file browser Version:
Keywords: webdav Cc:

Description

I have phTagr running and its working well on ubuntu server, but I'm curious how to access things via webdav. I am having trouble finding information on how to set it up, but when I access my server via http://server/phtagr/webdav I get prompted to login and nothing works. Is there some setup or something I am missing? I've tried from multiple OSes and various programs and everything has the same authentication issues.

Attachments

logger.log (20.1 KB) - added by dgBoldt 8 years ago.
Log file

Change History

comment:1 Changed 8 years ago by sebastian

  • Keywords webdav added
  • Owner set to sebastian
  • Status changed from new to accepted
  • Component changed from unspecified to file browser
  • Milestone set to 2.2

Thank you very much for reporting this issue and using phtagr!

WebDav describes how to use webdav with phtagr. Your given URL seems to be correct. What is your webdav client? Did you tried it with cadaver? Any hints in the logfile in tmp/logs/logger.log?

Which version of phtagr are you using currently?

Ticket #121 reports a broken webdav which was fixed something in April 2011. I uploaded the newest zip archive phtagr-master-e2d974b1.zip from master to SourceForge [1] which includes this fix. Please see HowToMigratePhtagr for updating the source.

Since I'm focusing on a new layout there is not much update on the main branch. See http://dev.phtagr.org for early birds and checkout the dev branch from GitHub [2] if you're interested.

[1] http://sourceforge.net/projects/phtagr/files/phtagr-master-e2d974b1.zip/download
[2] https://github.com/xemle/phtagr/tree/dev

Changed 8 years ago by dgBoldt

Log file

comment:2 Changed 8 years ago by dgBoldt

I've installed the up to date version of phtagr-master-e2d974b1 on two different servers, one that we setup locally and another on a external web server, all of which meet the software requirements.

Attached is the log file.

What would be the credentials to login to the webdav?

Webdav clients we used:
FireFox?
Chrome
Safari
Cyberduck
Built in mac connect to server
Same with windows

comment:3 Changed 8 years ago by sebastian

Hi,

thank you for your reply and your log file. About 2011-08-08 09:58:13 your trying to connect via webdav to phtagr and the webdav module requests HTTP Authentication Header. This is normal for the first request but the second request should contain this header. But following request do not have them either.

This could be caused by suPHP module which does not support Authentication Headers. There is a patch for the current 0.7.1 version of suPHP which should support the header but I never tested it. So if you have suPHP please try to disable it.

If you do not use suPHP you could check your network traffic with tcpdump or whireshark and send me your network trace for further investigation.

Xemle

PS: If you like to be updated on ticket changes, please add your email address or open your discussion at the mailing list.

comment:4 Changed 7 years ago by sebastian

  • Milestone changed from 2.2 to 2.4

comment:5 Changed 7 years ago by sebastian

  • Status changed from accepted to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.